RSS

[CCNA StandAloneLabs] Lab 13: RIP(Routing Information Protocol)

09 Jun

Bài viết liên quan: ,,,

Thông tin chung:

Chủ đề:

Thiết bị cần thiết: Chúng ta cần sử dụng 1 Router

Nội dung:

1. RIP là gì?

2. Cấu hình các ip cho các router

3. Thêm một phần tử vào định tuyến RIP.

4. Xem một phần tử trong định tuyến.


Bước thực hiện:

1.    RIP là gì?

          RIP là Routing Information Protocol. NÓ là một giao thức căn bản dựa trên thuật toán distance vector, là đo khoảng cách bằng cách tính số lượng hop trung gian đi qua. Nó được dùng để trao đổi thông tin định tuyến.

          RIP sử dụng số lượng hop để tìm kiếm đường đi tốt nhất giữa 2 điểm. Số lượng Hop là số lượng router mà một packet phải đi qua cho đến khi đến được địa chỉ đích.

          Trong mạng RIP, các router sẽ phát tán bảng RIP của mình cho các router cạnh kề sau mỗi 30 giây. Sau khi nhận được bảng RIP của hàng xóm, nó sẽ sử dụng để cập nhật lại bảng định tuyến chủa chính nó và gửi bản cập nhật đến các hàng xóm.

          Việc cấu hình RIP cho router là việc liệt kê các đường mạng kết nối trực tiếp đến router đó. Qua giao thức RIP, bảng định tuyến ở các hop khác sẽ được gửi đến và sẽ tự động cập nhật lại bẳng định tuyến của mình.

2.    Cấu hình các ip cho các router

          Chúng ta sẽ cấu hình các router theo bảng sau:

image

Router 1 kết nối với router 2 bằng kết nối cáp xoắn (Cross – Over)

Router 2 kết nối với router 4 bằng kết nối serial (DCE)

 

          Cấu hình tại Router 1:

Router>enable

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#inter Fast 0/0

Router(config-if)#ip address 10.1.1.1 255.255.255.0

Router(config-if)#no shutdown

 

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to upRouter(config-if)#exit

Router(config)#inter Ser 0/1/0

Router(config-if)#ip address 172.6.10.1 255.255.255.0

Router(config-if)#clock rate 64000

Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

Router(config-if)#end

Router#

 

          Cấu hình tại router 2:

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#inter Fast 0/0

Router(config-if)#ip address 10.1.1.2 255.255.255.0

Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#end

Router#

 

          Cấu hình tại Router 4:

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#inter Ser 0/1/0

Router(config-if)#ip address 172.6.10.2 255.255.255.0

Router(config-if)#no shutdown

 

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

Router(config-if)#

 

          Sau khi cấu hình, các Router sẽ hiển thị như hình vẽ. Chú ý là việc ping các máy phải chờ một thời gian để các máy cập nhật:

image

3.    Thêm một phần tử vào định tuyến RIP

          Tại Router1, ta sẽ thêm định truyến RIP theo các dòng lệnh sau:

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#router rip

Router(config-router)#network 10.0.0.0

Router(config-router)#network 172.16.0.0

Router(config-router)#

 

          Tại Router 2, ta sẽ thêm định tuyến như sau:

Router>enable

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#router rip

Router(config-router)#network 10.0.0.0

Router(config-router)#

 

          Tại Router 4, ta cũng thêm một định tuyến:

Router(config)#router rip

Router(config-router)#network 172.16.0.0

Router(config-router)#

 

          Sau khi cấu hình xong ta có thể thử lệnh ping giữa 2 mạng để kiểm tra kết quả. Từ Router 4 ta ping đến Router 2:

Router#ping 10.1.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 5/7/10 ms

 

Router#

 

          Kết quả thành công!

4.    Xem một phần tử trong định tuyến

          Để xem bảng định tuyến ta dùng lệnh:

Router#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

       * – candidate default, U – per-user static route, o – ODR

       P – periodic downloaded static route

 

Gateway of last resort is not set

 

R    10.0.0.0/8 [120/1] via 172.16.10.1, 00:00:16, Serial0/1/0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.10.0 is directly connected, Serial0/1/0

Router#

 

          Ở đây, kí hiệu R chỉ rằng định tuyến này là định tuyến RIP. Và thông tin này được cập nhật từ các hop lân cận và chính xác là 172.16.10.1 trong thời gian 16 giây trước tại cổng Serial 0/1/0

Written by hotdream1990

 
Leave a comment

Posted by on June 9, 2011 in CCNA

 

Tags: , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s